G43 JHP feed issues when slingshotting

G43 JHP feed issues when slingshotting

This is a discussion on G43 JHP feed issues when slingshotting within the Glock Troubleshooting and Maintenance forums, part of the Glock General Discussion category; Having issues with my Glock 43 feeding in the first round when I slingshot it into the chamber. If I lock the slide open and ...

Results 1 to 3 of 3
  1. #1
    Junior Member adammaund5's Avatar
    Join Date
    Mar 2020
    Posts
    2

    G43 JHP feed issues when slingshotting

    Having issues with my Glock 43 feeding in the first round when I slingshot it into the chamber. If I lock the slide open and then use slide stop to load first round it works fine. Slingshotting it almost seems to get stuck on the bottom of the ramp. If I smack the back of the slide most times it will go into battery fine. I cleaned the ramp so that shouldn’t be the issues.I’m using Hornady Critical Defense. It does not have this issue with the OEM 6 round mag. Only on the +2 taran tactical mag.

    I shot a mag of the stuff through yesterday and it shot fine. It is just the initial slingshot on occasion that causes it. Is this normal?

  2. #2
    Junior Member adammaund5's Avatar
    Join Date
    Mar 2020
    Posts
    2
    Also mention it works much better if I just add one round instead of 2 into the mag extension

  3. #3
    Senior Member cpippen's Avatar
    Join Date
    Mar 2015
    Location
    A Galaxy Far Far Away
    Posts
    2,066
    It’s a spring issue. My G43 wouldn’t reliably cycle with Pierce Grip extensions. I ended up just going back to factory mags and have had no problems.
    “In proper hands, the Glock serves just as well as the 1911 - at conversational distances. And such distances are the rule in defensive combat.”

    - Jeff Cooper

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •