Gen 4 Glock 19 (fires but will not eject)

Gen 4 Glock 19 (fires but will not eject)

This is a discussion on Gen 4 Glock 19 (fires but will not eject) within the Glock Troubleshooting and Maintenance forums, part of the Glock General Discussion category; This Glock is basically new, Iíve probably shot 400 rounds through it with not one single problem. Just recently it has become a one shot ...

Results 1 to 6 of 6
  1. #1
    Junior Member Jasrob2000's Avatar
    Join Date
    May 2020
    Posts
    3

    Gen 4 Glock 19 (fires but will not eject)

    This Glock is basically new, Iíve probably shot 400 rounds through it with not one single problem. Just recently it has become a one shot at a time weapon. Itís primarily stock; it has a killer innovations trigger, double diamond stainless barrel(which has been on since first shot was fired, and a killer innovation comp. I have swapped slides and they work on this frame, I have swapped this slide to other frames and it still will not ejected after firing. I have tried 15# and 18# guide rods with no change (also double checked all guide rods in other 19ís with no issues). I have tried other stock ejectors and a ZEV ejector all witch work in other 19ís but will not work with this slide. I check the extractor with other guns and it works. Itís like the slide isnít opening enough upon fire to eject. I am out of ideas.. any advice?? What am I missing?

  2. #2
    Junior Member Jasrob2000's Avatar
    Join Date
    May 2020
    Posts
    3
    Who knows, must be broke..

  3. #3
    Senior Member GlockGuide's Avatar
    Join Date
    Jun 2016
    Location
    Dallas, TX
    Posts
    130
    You do realize you are on a basically dead site (except for advertisers)?

    Any chance you have a custom slide cover plate on this gun? It sounds like the issue is in the extractor. Since youíve already swapped it into another gun, that leaves the plunger, spring and bearing. Custom slide plates can fubar the bearing but check all the parts.

    Also be sure the spring did not come out of the firing pin safety and get stuck in that channel although this seems unlikely if youíve already taken the extractor out.


    Sent from my iPhone using Tapatalk
    Follow me on Twitter
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Glock Advanced Certified Armorer
    Glock 500 Club
    NRA Certified Instructor

  4. Remove Advertisements
    GlockForum.net
    Advertisements

  5. #4
    Junior Member Jasrob2000's Avatar
    Join Date
    May 2020
    Posts
    3
    Lol starting to realize it’s a dead page. There is a ZEV slide cover plate, that is a new change as well. I took the slide off and put it in my safe. Put another one on that works for now. I’ve replaced every moving part in that slide now and it still won’t eject 1 round. I’m going to try removing comp and putting stock barrel back in it and if that doesn’t work...Probably take it to a professional someday.

  6. #5
    Senior Member NunquamNonParatus's Avatar
    Join Date
    Oct 2013
    Location
    TN
    Posts
    7,255
    Is it not extracting the round out of the chamber? If so you fucked up the extractor. Ever insert a round into the chamber then close the slide on it?

    Another thought is your whiz bag barrel chamber is too tight after you shoot. Stick the factory barrel in it and try that.

    Where's your factory RSA? Put it in.
    "Better to remain silent and be thought a fool than to talk out your ass and remove all doubt." A. Lincoln (sort of.)
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


    "It seems to me a certainty that the fatalistic teachings of Mohammed and the utter degradation of the Arab women are the outstanding causes for the arrested development of the Arab. He is exactly as he was around the year 700, while we have been developing." George S. Patton

    President/executive director of the NQNP STFU awards foundation.

  7. #6
    Senior Member GlockGuide's Avatar
    Join Date
    Jun 2016
    Location
    Dallas, TX
    Posts
    130
    Swap the cover plate back and check the little plastic bearing on the end of the extractor plunger spring as well for any uneven wear/damage.


    Sent from my iPhone using Tapatalk
    Follow me on Twitter
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    Glock Advanced Certified Armorer
    Glock 500 Club
    NRA Certified Instructor

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts